关于ThinkPHP 5.0.x存在远程代码执行漏洞的安全公告

2019-01-11 18:37:05
安全公告编号:CNTA-2019-0004

2019年1月11日,国家信息安全漏洞共享平台(CNVD)收录了ThinkPHP远程代码执行漏洞(CNVD-2019-01092)。攻击者利用该漏洞,可在未授权的情况下远程执行代码。目前,漏洞利用原理已公开,厂商已发布新版本修复此漏洞。

一、漏洞情况分析

ThinkPHP采用面向对象的开发结构和MVC模式,融合了Struts的思想和TagLib(标签库)、RoR的ORM映射和ActiveRecord模式,是一款兼容性高、部署简单的轻量级国产PHP开发框架。

2019年1月11日,ThinkPHP团队发布了版本更新信息,修复了远程代码执行漏洞。该漏洞是由于框架在对关键类Request处理过程中,通过变量覆盖实现对该类任意函数的调用,构造相应请求可对Request类属性值进行覆盖,导致任意代码执行。攻击者利用该漏洞,可在未经授权的情况下,对目标网站进行远程命令执行攻击。

CNVD对该漏洞的综合评级为“高危”。

二、漏洞影响范围

漏洞影响的产品版本包括:

ThinkPHP 5.0.x ~ 5.0.23版

CNVD秘书处对使用ThinkPHP框架的网站服务器进行探测,数据显示全球使用ThinkPHP框架的服务器规模共有4.3万;按国家分布情况来看,分布前三的分别是中国(3.9万)、美国(4187)和加拿大(471)。经CNVD秘书处进行技术验证,受此漏洞影响的ThinkPHP网站比率约为12%,影响比例较高。

三、漏洞处置建议

       目前,ThinkPHP厂商已发布新版本修复此漏洞,CNVD建议用户立即升级至最新版本:

http://www.automagiclaud.com/down.html

 

附:参考链接:

http://www.automagiclaud.com/top-think/framework/commit/4a4b5e64fa4c46f851b4004005bff5f3196de003

http://www.automagiclaud.com/down.html